XVERWEIS in Excel – Die bessere Alternative zu SVERWEIS!

Letztes Update: 31. Januar 2024

Anschauen auf YouTube & Kanal abonnieren

Einführung in XVERWEIS Excel: Eine leistungsstarke Alternative zu SVERWEIS und WVERWEIS

XVERWEIS (engl. XLOOKUP) ist eine relativ neue Funktion in Excel, die seit 2019 verfügbar ist und seitdem rasch an Beliebtheit gewonnen hat. Die Funktion ist besonders nützlich für die Datenanalyse und bietet dir eine effiziente und benutzerfreundliche Alternative zu den älteren SVERWEIS und WVERWEIS Funktionen.

Mit XVERWEIS kannst du Informationen aus Tabellen und Datenbanken auf einfache und präzise Weise suchen und abrufen. Im Gegensatz zu SVERWEIS und WVERWEIS bietet XVERWEIS eine höhere Flexibilität bei der Suche nach Daten in Excel-Tabellen.

Praktisches Beispiel für XVERWEIS (Interaktive Tabelle zum Ausprobieren)

In der folgenden Tabelle kannst du deine eigenen Werte eintragen. Probiere es einfach aus!

Die Syntax von XVERWEIS: Einfach und vielseitig

=XVERWEIS(Suchkriterien, Suchbereich, Rückgabebereich, [Wenn_nicht_gefunden], [Vergleichsmodus], [Suchmodus])

Die einzelnen Argumente lauten wie folgt:

  1. Suchkriterien: Der Wert oder die Bedingung, nach dem/der in der ersten Spalte oder Zeile des Suchbereichs gesucht werden soll.
  2. Suchbereich: Der Bereich, in dem nach dem Suchkriterium gesucht wird. Dies ist der Bereich, der die zu suchenden Daten enthält.
  3. Rückgabebereich: Der Bereich, aus dem die übereinstimmenden Daten zurückgegeben werden sollen.
  4. [Wenn_nicht_gefunden]: (Optional) Der Wert, der zurückgegeben wird, wenn das Suchkriterium nicht gefunden wird. Wird dieses Argument weggelassen, zeigt Excel standardmäßig einen Fehler an.
  5. [Vergleichsmodus]: (Optional) Bestimmt den Modus für den Vergleich der Suchkriterien. Beispielsweise können Sie hier festlegen, ob eine exakte Übereinstimmung erforderlich ist oder ob der nächstkleinere bzw. nächstgrößere Wert akzeptiert wird.
  6. [Suchmodus]: (Optional) Legt fest, wie die Suche durchgeführt wird, z.B. von oben nach unten oder von unten nach oben.

Anwendungsbeispiele: XVERWEIS in der Praxis

XVERWEIS ist ein äußerst vielseitiges Werkzeug in Excel und kann für eine Vielzahl von Anwendungsfällen genutzt werden. Hier sind einige praktische Beispiele, die die Nützlichkeit von XVERWEIS in verschiedenen Situationen illustrieren:

Natürlich, hier sind dieselben Anwendungsbeispiele für XVERWEIS in Excel, formuliert in der “Du-Form”:

1. Grundlegende Datenabfrage

  • Szenario: Du hast eine Mitarbeiterliste mit Namen, Abteilungen und Gehältern. Du kannst XVERWEIS verwenden, um das Gehalt eines bestimmten Mitarbeiters schnell zu finden.
  • Formel: =XVERWEIS("Max Mustermann", Mitarbeiterliste[Namen], Mitarbeiterliste[Gehälter])

2. Dynamischer Zellbezug

  • Szenario: In deiner Lagerbestandsliste möchtest du den aktuellen Bestand eines bestimmten Produkts herausfinden.
  • Formel: =XVERWEIS(A1, Produktliste, Bestandsliste)
  • Erklärung: Indem du den Suchwert in eine Zelle (z.B. A1) einträgst, kannst du einfach den Produktnamen ändern, ohne die Formel neu eingeben zu müssen.

3. Rückgabe eines ganzen Bereichs

  • Szenario: Du hast eine Tabelle mit Produktinformationen und möchtest alle Details zu einem bestimmten Produkt in einem anderen Tabellenblatt anzeigen.
  • Formel: =XVERWEIS(GesuchtesProdukt, Produktliste[Produktname], Produktliste[#Alle])
  • Erklärung: XVERWEIS kann einen ganzen Zeilen- oder Spaltenbereich zurückgeben, nicht nur einzelne Werte.

4. Umgang mit fehlenden Daten

  • Szenario: Du suchst nach Daten, die möglicherweise nicht in deiner Tabelle vorhanden sind, und möchtest eine benutzerdefinierte Fehlermeldung anzeigen, anstatt eines Standardfehlers.
  • Formel: =XVERWEIS(Suchkriterium, Suchbereich, Rückgabebereich, "Nicht gefunden")

5. Ungefähre Übereinstimmungen

  • Szenario: In einer Tabelle mit Leistungsbewertungen möchtest du die nächsthöhere Bewertungsstufe für einen bestimmten Punktestand finden.
  • Formel: =XVERWEIS(Punktestand, Bewertungspunkte, Bewertungsstufen, , 1)
  • Erklärung: Der Vergleichsmodus 1 findet den nächstgrößeren Wert.

6. Umgekehrte Suche

  • Szenario: Du möchtest den letzten Verkauf eines bestimmten Produkts in einer chronologisch geordneten Liste finden.
  • Formel: =XVERWEIS("Produkt X", Produktliste, Verkaufsdatenliste, , -1)
  • Erklärung: Der Suchmodus -1 sucht von unten nach oben, was ideal ist, um den letzten Eintrag zu finden.

Diese Beispiele demonstrieren, wie du XVERWEIS in verschiedenen Kontexten verwenden kannst, um Daten effizient zu suchen, abzufragen und anzuzeigen. Die Fähigkeit, sowohl exakte als auch ungefähre Übereinstimmungen zu finden, macht XVERWEIS zu einem sehr nützlichen Werkzeug für die Datenanalyse in Excel.

Deine Excel Online Schulung

Expertenskills Lernplattform

Mit Excel zum beruflichen Erfolg: Sichere deine Karriere und Zukunft durch effizientes Arbeiten mit Excel. Erlerne Fähigkeiten, die dich im Job voranbringen und deine Position stärken

Egal, ob du schon viel Erfahrung hast oder gerade erst anfängst – die Kurse bieten dir die Möglichkeit, deine Fähigkeiten auf ein ganz neues Level zu heben. Erweitere deine Expertise in verschiedenen Bereichen und entwickle dich weiter.

Auf der Lernplattform findest du alles, was du brauchst, um in deiner Karriere den nächsten großen Schritt zu machen. Sei gespannt, was du alles erreichen kannst – ich freue mich darauf, dich auf deiner Lernreise zu begleiten!


Tags

SVERWEIS, XVERWEIS


Vielleicht gefällt dir auch...

Gratis Download - Digitales Buch: 13 Excel-Formeln, ohne die du nicht überleben kannst - jetzt herunterladen!