SVERWEIS Alternative in Excel

Letztes Update: 10. Februar 2024

Excel-Enthusiasten wie ich nutzen die Excel SVERWEIS-Funktion ständig, um Daten aus anderen Tabellen zu suchen und abzurufen. Aber was, wenn SVERWEIS deine Bedürfnisse nicht vollständig erfüllt? Vielleicht hast du Schwierigkeiten mit der Leistung bei großen Datensätzen oder möchtest flexiblere Suchkriterien. Hier kommen SVERWEIS Alternativen ins Spiel.

Anschauen auf YouTube & Kanal abonnieren

Wozu braucht man SVERWEIS nochmal?

Stell dir vor, du verwaltest die Inventarliste eines kleinen Unternehmens. Du möchtest schnell den Preis eines bestimmten Artikels herausfinden, aber die Artikel sind nicht in aufsteigender Reihenfolge angeordnet.

Inventarliste

ArtikelnummerArtikelnamePreis (€)
1001Kugelschreiber1,50
1002Notizbuch3,00
1003Taschenrechner10,00
1010USB-Stick8,00

Mit SVERWEIS könntest du jetzt zu jeder beliebigen Artikelnummer den Namen und den Preis heraussuchen. Das ist besonders oft nützlich, wenn du mit mehreren Tabellen arbeitest. Nehmen wir einmal an du hast eine andere Tabelle mit Bestellungen:

Bestellungen

BestellnummerArtikelnummerBestellmenge
5001100120
5002100315
5003101010
501010025

Dann könntest du dir mit Hilfe von SVERWEIS beispielsweise die Preise aus der Inventarliste in die Liste der Bestellungen dazu spielen. Hier am konkreten Beispiel.

Beispiel SVERWEIS

SVERWEIS Beispiel

Hier habe ich diese Formel verwendet:

=SVERWEIS(F3;$A$3:$C$6;3;0)*G3

Im Falle H3 ergibt das 1,5*20 = 30

Wie du vielleicht siehst, suche ich mir den Wert aus F3 (also die Artikelnummer) aus dem Bereich A3:C6 heraus und multipliziere ihn danach mit G3 (also der Bestellmenge). Heraus kommt der Gesamtpreis. Schau dir bitte meinen Post zu SVERWEIS an, um die Formel genauer zu verstehen. Du kannst übrigens die Tabelle hier im Downloadbereich herunterladen.

Übrigens, hier ist der Artikel zu Dollarzeichen in Excel, falls du die noch nicht kennst.

Alternative 1: XVERWEIS in Excel

Wenn ich XVERWEIS als SVERWEIS Alternative nutze, sieht die Formel ganz anders aus, ergibt aber das gleiche Ergebnis

XVERWEIS als SVERWEIS Alternative

Die Formel hier lautet:

=XVERWEIS(F3;A:A;C:C;;0)*G3

Wie du siehst, kann ich hier etwas großzügiger sein, indem ich die kompletten Spalten A und C als Such- bzw. Ergebnisbereich nutze. XVERWEIS gilt als schnellere, modernere und flexiblere Variante zu SVERWEIS. Du kannst damit beispielsweise auch von rechts nach links suchen.

Nutze unbedingt XVERWEIS, wenn deine Excel-Version das unterstützt!

Dieses Beispiel findest du auch im Downloadbereich.

Alternative 2: INDEX und VERGLEICH in Excel

Es gibt noch eine SVERWEIS Alternative: Die klassische Kombination aus INDEX und VERGLEICH.

INDEX / VERGLEICH

Die Formel hier lautet:

=INDEX(C:C;VERGLEICH(F3;A:A;0))*G3

Hiermit simuliere ich einen XVERWEIS. Wenn Du XVERWEIS bereits in deiner Excel-Version hast, brauchst du dies nicht. Falls doch, ist diese Variante sehr zu empfehlen, da du auch hier komplette Spalten statt einer Matrix nutzen kannst und ebenfalls von rechts nach links suchen kannst.

Ich benutze als Eselsbrücke immer dieses Beispiel:

=INDEX(E:E;VERGLEICH(A1;S:S;0))

Dabei ist E:E der Ergebnisbereich und S:S der Suchbereich. Ich merke es mir an den Anfangsbuchstaben.
A1 ist der Wert, der gefunden werden soll.

Weiter geht es hier

Expertenskills Lernplattform

Mit Excel zum beruflichen Erfolg: Sichere deine Karriere und Zukunft durch effizientes Arbeiten mit Excel. Erlerne Fähigkeiten, die dich im Job voranbringen und deine Position stärken

Egal, ob du schon viel Erfahrung hast oder gerade erst anfängst – die Kurse bieten dir die Möglichkeit, deine Fähigkeiten auf ein ganz neues Level zu heben. Erweitere deine Expertise in verschiedenen Bereichen und entwickle dich weiter.

Vielen Dank und viele Grüße!
Dein Sebastian Glöckner


Tags

INDEX, SVERWEIS, VERGLEICH, XVERWEIS


Vielleicht gefällt dir auch...

Gratis Download - Digitales Buch: 13 Excel-Formeln, ohne die du nicht überleben kannst - jetzt herunterladen!