Excel WENN DANN Funktion leicht gemacht – Ein praktischer Leitfaden

Letztes Update: 31. Januar 2024

In Excel kannst du Funktionen mit Bedingungen verwenden, um komplexere Tabellenanalysen durchzuführen. Die wohl bekannteste Funktion dafür ist die sogenannte Excel WENN DANN Funktion. Mit der WENN-DANN-Funktion kannst du eine Bedingung prüfen (zum Beispiel Ist der Wert in Zelle A1 größer als 1000?), und wenn diese erfüllt ist, einen bestimmten Wert zurückgeben. Ansonsten wird ein anderer Wert zurückgegeben (also im obigen Beispiel wäre das der Fall, wenn der Wert in Zelle A1 kleiner oder gleich 1000 ist).

Anschauen auf YouTube & Kanal abonnieren

Worum geht es bei der WENN DANN Funktion in Excel?

Mit der Excel WENN DANN Funktion kannst du deiner Tabelle beibringen, Entscheidungen zu treffen. Du kannst logische Tests ausführen, wie z.B. ob eine Zahl größer als 10 ist oder nicht, und basierend auf den Ergebnissen entsprechende Aktionen ausführen. In diesem Blog-Beitrag erfährst du alles, was du über Wenn-Dann-Funktionen wissen musst und wie du sie in deinen Excel-Tabellen effektiv nutzen kannst.

Wie man die Wenn-Dann-Funktion in Microsoft Excel verwendet

Die Syntax lautet wie folgt:

=WENN(Bedingung; Wert_wenn_wahr; Wert_wenn_falsch)

Hier am obigen Beispiel erläutert:

=WENN(A1>1000;"Der Wert in Zelle A1 ist größer als 1000!";"Der Wert ist kleiner oder gleich 1000.")
WENN DANN Formel in Excel. Einfaches Beisspiel
WENN DANN Formel in Excel mit einer einfachen Bedingung.

Der Ausdruck A1>1000 ist die Bedingung. A1>1000 ist ein logischer Vergleich von zwei Werten, deswegen kommt als Ergebnis immer wahr oder falsch heraus. Wenn die Bedingung wahr ist, wird der angegebene Wert_wenn_wahr ausgegeben. Wenn die Bedingung falsch ist, wird der angegebene Wert_wenn_falsch ausgegeben.

Beispielsweise kannst du eine Wenn-Dann-Funktion für die Auswertung deiner Excel-Tabellen verwenden. Wenn ein bestimmtes Kriterium erfüllt ist, kannst du einen bestimmten Wert aus einer anderen Zelle anzeigen. Es ist auch möglich, mehrere Bedingungen zu kombinieren, indem du die UND- oder ODER-Funktion einbaust, oder du kannst mehrere Wenn-Dann-Funktionen ineinander verschachteln (mehr dazu im nächsten Absatz).

Wie man eine WENN-Funktion mit mehreren Bedingungen verwendet

Manchmal möchtest du eine Funktion verwenden, mit der du auf mehrere Bedingungen reagieren kannst. Mit der Funktion WENN in Excel kannst du auch mehrere Bedingungen kombinieren und so auf mehrere Ergebnisse reagieren.

Möglichkeit 1: Verwendung der Excel UND bzw. Excel ODER Funktion

Hier ein kleines Beispiel, bei dem zwei Bedingungen gleichzeitig gelten sollen.

  1. Der Wert in Zelle A1 soll größer als 800 sein.
  2. Der Wert in Zelle A1 soll gleichzeitig kleiner als 1000 sein.

Die passende Formel würde so aussehen:

=WENN(UND(A1>800;A1<1000);"Der Wert ist zwischen 800 und 1000.";"Der Wert ist zu klein oder zu groß.")

Hier ein Screenshot aus Excel:

Excel WENN DANN FUNKTION
WENN DANN Funktion in Excel mit zwei Bedingungen.

Möglichkeit 2: Excel WENN DANN Funktion verschachteln

Mit den UND oder ODER-Funktionen in Excel kann man sehr praktisch zwei Bedingungen gleichzeitig abfragen (bei UND müssen beide Bedingungen erfüllt sein, bei ODER mindestens eine).

Allerdings gibt es auch komplexere Fälle, wie zum Beispiel diesen hier:

  1. Wenn der Wert in A1 kleiner 800 ist, gib den Wert “Small” aus.
  2. Wenn er kleiner als 1000 ist (aber größer/gleich 800), gib den Wert “Medium” aus.
  3. Wenn er 1000 oder größer ist, gib den Wert “Large” aus.
=WENN(A1<800;"Small";WENN(A1<1000;"Medium";"Large"))
Excel WENN DANN Funktion verschachtelt
Verschachtelte WENN DANN Funktion in Excel

Im obigen Beispiel sind zwei WENN-Funktionen ineinander verschachtelt. Da Excel die Funktionen von links nach rechts abarbeitet, liest sich das Ganze in etwa so:

Wenn A1 kleiner als 800 ist: “Small”. Sonst: Wenn er kleiner als 1000 ist: “Medium”. Sonst: “Large”

Das bedeutet, der Wert_wenn_falsch aus der WENN-Formel besteht wiederum aus einer eigenen WENN-Formel. Auf diese Weise kannst du Excel-Formeln beliebig oft “stapeln” bzw. ineinander verschachteln.

Fazit und Excel Online Schulung

Excel bietet eine intuitiv bedienbare Benutzeroberfläche mit vielen Funktionen, aber die Wenn-Dann-Funktion ist überraschend nützlich, wenn es darum geht, Tabellen zu organisieren und Prozesse zu automatisieren. Obwohl die Wenn-Dann-Funktion ein paar knifflige Details enthalten kann, ist sie im grundlegenden sehr einfach zu verstehen und zu benutzen.

Expertenskills Lernplattform

Mit Excel zum beruflichen Erfolg: Sichere deine Karriere und Zukunft durch effizientes Arbeiten mit Excel. Erlerne Fähigkeiten, die dich im Job voranbringen und deine Position stärken

Egal, ob du schon viel Erfahrung hast oder gerade erst anfängst – die Kurse bieten dir die Möglichkeit, deine Fähigkeiten auf ein ganz neues Level zu heben. Erweitere deine Expertise in verschiedenen Bereichen und entwickle dich weiter.

Auf der Lernplattform findest du alles, was du brauchst, um in deiner Karriere den nächsten großen Schritt zu machen. Sei gespannt, was du alles erreichen kannst – ich freue mich darauf, dich auf deiner Lernreise zu begleiten!


Tags

Funktionen, WENN


Vielleicht gefällt dir auch...

Gratis Download - Digitales Buch: 13 Excel-Formeln, ohne die du nicht überleben kannst - jetzt herunterladen!